Instalar apxs2 en Ubuntu

Hace unos días tuve que compilar cierto módulo para apache, el problema vino cuando me pedía como requisito para compilar apxs2. Pues bien para tener  apxs2 en Ubuntu sólo hay que instalar el siguiente paquete:

 $ sudo aptitude install apache2-threaded-dev

Y ahora apxs2 estará instalado en la ruta

 /usr/bin/apxs2

Espero que les sea de ayuda como a mi.

3 thoughts on “Instalar apxs2 en Ubuntu

  1. Yessica

    Hola!
    Estoy instalando el paquete opentsa http://www.opentsa.org, actualemente estoy en el punto de instalar el modulo para apache que permite establecer el servicio de estampado de tiempo, sin ambrago cuando ejecuto el make install al modulo mod_tsa, me genera el siguiente error con apxs2:

    chmod 644 /usr/lib/apache2/modules/mod_tsa.so
    apxs:Error: Activation failed for custom /etc/apache2/httpd.conf file..
    apxs:Error: At least one `LoadModule’ directive already has to exist..
    make: *** [install] Error 1

    Tendràs idea de que puede ser?
    Gracias!

  2. miguel

    revisa el makeFile del instalador
    apunta a otra ubicacion

    /usr/sbin/apxs2 en ubuntu no aparece pero mejor crea un enlace simbolico a la ruta y todo OK

    sudo ln /usr/bin/apxs2 /usr/sbin/apxs

Comments are closed.